Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
sitehelpdesk  
#1 Posted : Tuesday, March 26, 2013 2:35:24 AM(UTC)
sitehelpdesk

Rank: Newbie

Groups: Registered
Joined: 3/26/2013(UTC)
Posts: 1

Hi, please can anyone help – I’m struggling!!!

We have previously used EAGetEmail to access mailbox via IMAP and POP3 in ASP web pages without any issue. Now we are trying to access using EWS. We can connect to the server/mailbox but no emails are returned. I think this is because it is not looking in the Inbox folder. How can we used SelectFolder to set to use Inbox. Here is the code....


<!--#include file="MailConst.asp"-->

<%
Dim oClient, oServer

Set oClient = Server.CreateObject("EAGetMailObj.MailClient")
oClient.LicenseCode = "XXXXXXXXXXXXXXXXXXXXXXXX"
Set oServer = Server.CreateObject("EAGetMailObj.MailServer")

oServer.Server = MailServer
oServer.User = MailID
oServer.Password = MailPass
oServer.Protocol = 2
oServer.SSLConnection = True

oClient.Connect oServer

arInfo = oClient.GetMailInfos()

response.write "Error : " & Err.Description
response.write "Count : " & ubound(arInfo)


%>
ivan  
#2 Posted : Friday, March 29, 2013 8:01:37 AM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,014

Thanks: 9 times
Was thanked: 41 time(s) in 41 post(s)
sitehelpdesk wrote:
Hi, please can anyone help – I’m struggling!!!

We have previously used EAGetEmail to access mailbox via IMAP and POP3 in ASP web pages without any issue. Now we are trying to access using EWS. We can connect to the server/mailbox but no emails are returned. I think this is because it is not looking in the Inbox folder. How can we used SelectFolder to set to use Inbox. Here is the code....


<!--#include file="MailConst.asp"-->

<%
Dim oClient, oServer

Set oClient = Server.CreateObject("EAGetMailObj.MailClient")
oClient.LicenseCode = "XXXXXXXXXXXXXXXXXXXXXXXX"
Set oServer = Server.CreateObject("EAGetMailObj.MailServer")

oServer.Server = MailServer
oServer.User = MailID
oServer.Password = MailPass
oServer.Protocol = 2
oServer.SSLConnection = True

oClient.Connect oServer

arInfo = oClient.GetMailInfos()

response.write "Error : " & Err.Description
response.write "Count : " & ubound(arInfo)


%>


I received your email and solved the problem by a newer version of EAGetMail.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.054 seconds.

EXPLORE TUTORIALS

© All Rights Reserved, AdminSystem Software Limited.