Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
ditte  
#1 Posted : Tuesday, March 29, 2011 2:01:20 PM(UTC)
ditte

Rank: Member

Groups: Registered
Joined: 2/5/2011(UTC)
Posts: 15
Location: Germany, Berlin

Hi,

I´m using AOSMTP and ANPOP last years. Now I have make the change to EAGetMail and EASendMail.
I´ve not found the GetTotalOfMails anymore. How can I find out, how much mails are in the postfolder?

Regards Dittmar
ivan  
#2 Posted : Tuesday, March 29, 2011 3:39:04 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,012

Thanks: 9 times
Was thanked: 37 time(s) in 37 post(s)
Hi,

in EAGetMail, there is no GetTotalOfMails method. Please see the following code.

Code:

    oClient.Connect oServer
    MsgBox "Connected"
    
    Dim infos
    infos = oClient.GetMailInfos()
    MsgBox UBound(infos) + 1 & " emails"  ' emails counts



I also suggest that you have a look at this tutorial: retrieve email and parse email in vb6
ditte  
#3 Posted : Tuesday, March 29, 2011 11:37:20 PM(UTC)
ditte

Rank: Member

Groups: Registered
Joined: 2/5/2011(UTC)
Posts: 15
Location: Germany, Berlin

Hi,

it was helpfull. I read the tutorial.

Normaly I test the samples in VB6, but I can´t start it at time. It will need a ieframe.dll. At my station is the ieframe.dll in the ..\system32 folder but it isn´t that it like??

ivan  
#4 Posted : Wednesday, March 30, 2011 2:54:27 AM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,012

Thanks: 9 times
Was thanked: 37 time(s) in 37 post(s)

What is your operating system? This sample can be run on XP or later version very well.
the iframe.dll is a part of internet control(web browser),
In the sample, this control is used to display the html email.
I suggest that you upgrade your IE to 6.0 or later
ditte  
#5 Posted : Wednesday, March 30, 2011 4:18:12 AM(UTC)
ditte

Rank: Member

Groups: Registered
Joined: 2/5/2011(UTC)
Posts: 15
Location: Germany, Berlin

Hi,

System is XP SP3
IExplorer 8.0.6001.18702
ieframe 8.0.6001.19019 (in C:\windows\system32)

Error at opening (File not found:`C:\WINDOWS\system32\ieframe.dll\1`loading continue?)

Maybe a problem of many users. I´m searching in the web for a solution
ditte  
#6 Posted : Wednesday, March 30, 2011 4:31:55 AM(UTC)
ditte

Rank: Member

Groups: Registered
Joined: 2/5/2011(UTC)
Posts: 15
Location: Germany, Berlin

Hi,

there are e registry entry like ieframe.dll\1

i´ve cleared it and now it works.
Thanks
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.059 seconds.

EXPLORE TUTORIALS

© All Rights Reserved, AdminSystem Software Limited.