Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
snorek  
#1 Posted : Wednesday, February 16, 2011 4:54:49 AM(UTC)
snorek

Rank: Newbie

Groups: Registered
Joined: 2/16/2011(UTC)
Posts: 3

Hi,

When connecting to the server Oracle OCS through IMAP4
I get the error: Missing required argument to LOGIN
Server, login and password are correct.

Edited by moderator Friday, February 18, 2011 4:38:36 PM(UTC)  | Reason: Not specified

ivan  
#2 Posted : Wednesday, February 16, 2011 4:37:15 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,014

Thanks: 9 times
Was thanked: 41 time(s) in 41 post(s)
snorek wrote:
Hi,

When connecting to the server Oracle OCS through IMAP4
I get the error: Missing required argument to LOGIN
Server, login and password are correct.


Please generate a log file with LogFileName property and paste the log content here.
Please hide the password in the log content
snorek  
#3 Posted : Thursday, February 17, 2011 12:37:29 AM(UTC)
snorek

Rank: Newbie

Groups: Registered
Joined: 2/16/2011(UTC)
Posts: 3

Resolving server ...
Server: ServerURI
Port: 143
AuthType: AuthLogin
User: UserName
Password: UserPasswd
SSLConnection: False
SSLType: ConnectSSLAuto
Protocol: Imap4
SocksProxyServer:
SocksProxyPort: 1080
SocksProxyUser:
SocksProxyPassword:
ProxyProtocol: Socks5

Create socket InterNetwork,Stream,Tcp ...
Start to connecting ...
serverIP, 143
Connected

* OK server ready. Unauthorized Access Prohibited.
A0002 LOGIN UserName UserPasswd
A0002 BAD Missing required argument to LOGIN
ivan  
#4 Posted : Thursday, February 17, 2011 5:09:47 PM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,014

Thanks: 9 times
Was thanked: 41 time(s) in 41 post(s)
snorek wrote:
Resolving server ...
Server: ServerURI
Port: 143
AuthType: AuthLogin
User: UserName
Password: UserPasswd
SSLConnection: False
SSLType: ConnectSSLAuto
Protocol: Imap4
SocksProxyServer:
SocksProxyPort: 1080
SocksProxyUser:
SocksProxyPassword:
ProxyProtocol: Socks5

Create socket InterNetwork,Stream,Tcp ...
Start to connecting ...
serverIP, 143
Connected

* OK server ready. Unauthorized Access Prohibited.
A0002 LOGIN UserName UserPasswd
A0002 BAD Missing required argument to LOGIN


It seems that your IMAP4 server doesn't support the standard Login.
Please try to use

oServer.AuthType = ServerAuthType.AuthCRAM5;
oClient.Connect( oServer );

If it still doesn't work, please kindly send your server address, user/password to support@emailarchitect.net so that I can have a remote test to see what method your server supports.



snorek  
#5 Posted : Friday, February 18, 2011 12:41:03 AM(UTC)
snorek

Rank: Newbie

Groups: Registered
Joined: 2/16/2011(UTC)
Posts: 3

Hi,

Problem solved:
If the password contains special characters like *()
, the password must be given in "".

MailServer mailServer = new MailServer("ServerName", "UserName", ""pa$$word"", ServerProtocol.Imap4);

not(sic!)

MailServer mailServer = new MailServer("ServerName", "UserName", "pa$$word", ServerProtocol.Imap4);

The Problem appeared only with OCS server.

Thanks for all replies :)

--
Regards
snorek

Edited by user Friday, February 18, 2011 12:44:48 AM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.080 seconds.

EXPLORE TUTORIALS

© All Rights Reserved, AdminSystem Software Limited.