Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Tractivity  
#1 Posted : Monday, July 20, 2015 2:23:51 AM(UTC)
Tractivity

Rank: Newbie

Groups: Registered
Joined: 7/20/2015(UTC)
Posts: 0

Hi,

We use the EASendmail Component and the EASendMailService to send email newsletters to subscribers. Recently, GMail has started marking these as spam.

We have investigated this, and found that if EASendMailService is configured to send direct - acting as it's own SMTP server, then we see the problem.

However, we also have another SMTP server on the same box, and if we configure EASendMailService to relay through the other SMTP server (which has the same IP address and hostname) then GMail doesn't mark the mail as Spam.

In testing, using the same HTML content for both, the only differences that we can find in the Headers of the Email are that the EASendMailService connects to GMail using HELO, and our other SMTP Server uses EHLO, and also there is an extra step in the received path where the EASendMail SMTP Component sends the mail to the EASendMail Service, which appears in the headers like this:

Received: from mx.tractivity.co.uk ([127.0.0.1]) by mx.tractivity.co.uk ([127.0.0.1]) with SMTPSVC;

This line, and specifically the localhost address, doesn't appear in the emails sent using the relay.

We believe that it is the inclusion of the localhost IP in the headers which is causing GMail to mark emails as Spam.


Can anyone suggest how we might address this issue?

Thanks very much

Al.
ivan  
#2 Posted : Monday, July 20, 2015 7:21:49 AM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,014

Thanks: 9 times
Was thanked: 41 time(s) in 41 post(s)
Hi, I thought you should deploy SPF record and DKIM for your domain if you send email directly by EASendMail Service.

DKIM:
https://www.emailarchite...dk/?ct=object_domainkeys

SPF:
http://www.microsoft.com...ologies/senderid/wizard/
Tractivity  
#3 Posted : Tuesday, July 21, 2015 4:17:08 AM(UTC)
Tractivity

Rank: Newbie

Groups: Registered
Joined: 7/20/2015(UTC)
Posts: 0

Hi Ivan, we already have DKIM and SPF on the domain, but the mail is still marked as spam when the EASendmail Service sends direct.

Thanks,

Al.
ivan  
#4 Posted : Tuesday, July 21, 2015 6:16:09 AM(UTC)
ivan

Rank: Administration

Groups: Administrators
Joined: 11/11/2010(UTC)
Posts: 1,014

Thanks: 9 times
Was thanked: 41 time(s) in 41 post(s)
Hi, please have a test for your SPF and DKIM by the following tool:

http://www.appmaildev.com/en/dkim/

Please make sure you sent the test email by EASendMail Service directly.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.057 seconds.

EXPLORE TUTORIALS

© All Rights Reserved, AdminSystem Software Limited.